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1. Input and Output Devices
Answers of Book

Do and Learn!
1. Fill in the blanks.

Ans. (a)  Devices that are connected to the computer are also called 
peripheral devices.

  (b)  Input devices are used to provide information to the 
computer.

  (c)  Scanner is an input device that works like a photocopy 
machine.

  (d) A printer is an output device.
  (e)  Headphones are fi tted with speakers as well as a 

microphone.

2. State whether True (T) or False (F).

Ans. (a) Input devices are necessary for a computer. T

  (b) Speakers are input devices. F

  (c) A printer works with the help of a ball. F

  (d) A CRT monitor has a fl at screen. F

  (e) Laser printers are very fast. T

3. Tick () the correct option.
Ans. (a) Which of the following explains an input device?

 (i) It displays the result.  
 (ii) Its result comes out in printed form.   
 (iii) It gives data to the computer. 
 (iv) None of the above.     
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  (b)  Which of the following devices is used to read information 
from bank cheques?

 (i) Scanner  (ii) MICR   

 (iii) Digital camera (iv) Microphone 
(c) This printer prints by spraying ink on the paper.

 (i) Dot-matrix printer (ii) Laser printer   

 (iii) Inkjet printer  (iv) All of these 
(d) Trackballs work similar to a mouse.

 (i) Trackballs   (ii) Keyboards   

 (iii) Speakers  (iv) Scanners 
  (e) Which of the following is not an output device?

 (i) Printer   (ii) Monitor   

 (iii) Touch Screen (iv) Speakers 

4. Answer the following questions.
 (a) How are input devices important for a computer?

Ans.  They help in providing input to the computer without which a 
computer can’t work.

 (b) Name any fi ve input devices.
 Ans. Keyboard, Mouse, Scanner, Touch Screen, Light Pen.
 (c) What are the different types of printers? Write one line about 
  each.
 Ans. There are two types of printers:
   (i)  Impact Printers     (ii)  Non-Impact Printers

Impact Printers:  In this type of printer, hammers or pins (print 
heads) strike against a ribbon and paper to print the text.
Examples: Dot Matrix, Daisy Wheel, Line printer
Non-Impact Printers: Non-impact printers print without striking 
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the page. In other words, there is no contact between the print 
head and the paper.
Examples: Inkjet and Laser printers

 (d) How does a digital camera work?
 Ans.  A digital camera is an input device that takes pictures like a 

regular camera, but stores the images as data on a memory 
card instead of printing them on film. Many digital cameras 
are capable of recording videos in addition to taking photos. 
The pictures can be stored on a computer.

 (e) What are output devices? Name any three output devices.
 Ans. Devices that help us see the result of the input entered into 

a computer are known as output devices. For example: 
headphones, speakers, monitor, etc.

Computer Time
Open MS Word 2013 and type the following.
Ans. Do it yourself.
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Answers of Suggested Class Activities

 1. rtmooni 

 2. ctoprume scae  

 3. kradoyeb 

 4. meosu 
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 9. mrteip 

 10. bceasl 

 11. hfl as ievdr 

 12. cannres 

 13. DDV 

 14. hrda skdi 

 15. eorwp upslpy 
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Monitor

Computer case
Keyboard

Mouse

Webcam
Microphone

Speakers

Headphones

Printer

Cables

Flash drive

Scanners

DVD

Hard disk

Power supply

Answers of Worksheet

 I. 1. peripheral devices 2. input devices 3. Cathode-Ray Tube
  4. output device 5. MICR
 II.  1. T 2. F 3. T 4. T 5. F
 III.  1. (c) 2. (d) 3. (e) 4. (a) 5. (b)



41New Computer Power 4 TRM

2. Memory and Storage
Answers of Book

Let’s Do it!
Take a piece of paper and write down the phone numbers and dates 
of birth of fi ve of your good friends. Read this information once daily 
and try to memorise it. Do this exercise regularly for fi ve days. On the 
sixth day, take another piece of paper and try to remember the phone 
numbers and dates of birth of all fi ve friends.
How many could you write correctly?

Ans. Do it yourself.

Do and Learn!

1. Fill in the blanks.
Ans. (a) A computer’s brain is known as memory.

  (b) Primary memory is also known as volatile memory.
  (c) RAM stands for Random Access Memory.
  (d) Pen drive is an example of a secondary storage device.
  (e)  A CD is inserted into a CD Drive that can be found in the 

CPU box.

2. State whether True (T) or False (F).

Ans. (a) We can never forget things stored in our brain. F

  (b) ROM is temporary in nature. F

  (c) RAM comes in the form of a chip. T

  (d) A CD is square in shape. F

  (e) A pen drive can be easily carried in a pocket. T
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3. Tick () the correct option.
Ans. (a) The full form of DVD is Digital Versatile Disc.

(i) Digital Varied Disc
(ii) Digital Versatile Disc
(iii) Diagonal Versatile Disc
(iv) Digital Volatile Disc

  (b) RAM and ROM are types of Primary memory.
   (i) Flash (ii) Optical
   (iii) Primary (iv) Secondary
  (c) Which of the following is not a secondary storage device?
   (i) Pen drive (ii) DVD
   (iii) Blu-ray disc (iv) ROM
  (d)  The smallest amount of data that can be stored in a 

computer is Byte.
   (i) Byte (ii) Gigabyte
   (iii) Kilobyte (iv) Petabyte

(e) 1 Kilobyte = 1024 Bytes.
   (i) Bits (ii) Bytes
   (iii) Megabytes (iv) Gigabytes

4. Answer the following questions.
 (a) Mention any one difference between the human brain and 
  computer memory.

Ans.  A human brain may forget but information in the computer’s 
memory can be saved forever.

 (b) What are the different types of computer memory? Write one 
  line about each.

Ans.  A computer has two types of memory, primary memory and 
secondary memory. Primary memory holds only the data and 
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instructions on which the computer is presently working. It is 
called volatile memory as the data saved here is temporary in 
nature. Primary memory is further divided into the following:

   1. RAM (Random Access Memory)
   2. ROM (Random Only Memory)

Primary memory is expensive as well as limited. If we want 
to store a large amount of data or programs permanently, 
we need a cheaper and permanent memory. Such memory 
is called secondary memory. Secondary memory is stored in 
secondary storage devices, such as hard disk, CD (Compact 
Disc), DVD (Digital Versatile Disc) and pen drive.

 (c) Write a short note on the hard disk.
Ans.   Hard disk is the most important secondary storage device 

in a computer. In fact, it is an integral part of any computer 
system. When we save our work by clicking the Save button, the 
work is saved in the hard disk drive. 

   The hard disk can store a large amount of data. Hard disks can 
be internal or external, but normally, they are present inside the 
CPU box.

 (d) Differentiate between:
(i) CD and DVD   (ii) RAM and ROM

Ans.  (i) CD or Compact Disk is a circular disk that uses laser rays 
to read and write data. CDs are very cheap and have a 
storage space of 700 MB. They are inserted into CD drives 
fi tted in the CPU box. They are very convenient to use and 
carry with you.

    A DVD (Digital Versatile Disc) is similar to a CD in shape and 
size. The only difference is in the storage capacity. The 
storage capacity of a DVD is around 4.7 GB, which is more 
than that of a CD.

   (ii) RAM or Random Access Memory is the internal memory of 
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the CPU. It is used for storing data, programs and program 
results. It is a read/write memory which means that the data 
is stored until the computer is on. As soon as the computer 
is switched off, the data gets erased.

      ROM stands for Read Only Memory. It is the memory from
which we can only read but cannot write on it. In other 
words, we cannot make any changes in the data stored in 
ROM. 

 (e) RAM is volatile in nature. Justify the statement by giving reason.
Ans.   Information stored in RAM is temporary as the moment we switch 

off the computer, the RAM gets cleared. Therefore, RAM is 
volatile in nature.

Computer Time
Open MS Word 2013 and using drawing tools, draw the 
following. Take help from your teacher.
Ans. Do it yourself.

Answers of Suggested Class Activities
Ans. Do it yourself.

Answers of Worksheet

 I. 1. (d) 2. (a) 3. (e) 4. (c) 5. (b)
 II.  1. False 2. True 3. False 4. False 5. False
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 III. RAM
RAM or Random Access 
Memory is the internal memory 
of the CPU. It is used for 
storing data, programs and 
program result. It is a read/
write memory which means 
that the data is stored until the 
computer is on. As soon as the 
computer is switched off, the 
data gets erased.

ROM
ROM stands for Read Only 
Memory. It is the memory 
from which we can only read 
but cannot write on it. In other 
words, we cannot make any 
changes in the data stored in 
ROM. This type of memory 
is non-volatile. This means 
that the information is stored 
permanently. ROM stores such 
information or instructions 
that are required to start a 
computer. ROM chips are not 
only used in computers but 
also in other electronic items 
like washing machines and 
microwave ovens.
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3. More About Windows 8.1
Answers of Book

Let’s Do it!

Can you label the Windows 8.1 desktop in the picture given below?
Ans. 

Desktop
Icons

Desktop 
Background

Mouse Pointer

Date and Time

Notifi cation AreaTaskbarStart Button

Do and Learn!

1. Fill in the blanks.
 (a) Windows 8.1 is an operating system developed by Microsoft 
  Corporation.
 (b) The desktop background is also called a wallpaper.
 (c) An individual document is called a fi le.
 (d) Group of related fi les is stored in a folder.
 (e)  The Navigation buttons are used to switch between folders in 

the File Explorer window.
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2. State whether True (T) or False (F).
Ans. (a) The Weather app is an example of a live tile on the 

   Windows 8.1 Start screen. T
  (b) There is only a single option of a desktop wallpaper
   on the screen.   F
  (c) The desktop background is a moving picture on the 
   screen.   F
  (d) A fi le is a collection of related folders. F
  (e) We can rename any fi le or folder saved on the computer. 

T
3. Tick () the correct option.

Ans. (a)  Which of the following options is used to change the desktop 
background?

   (i) Down-arrow (ii) Live tiles
   (iii) Personalization (iv) File Explorer  
  (b)  Which of the following components of the File Explorer 

window has tabs?
   (i) Navigation pane (ii) Search bar
   (iii) Address bar (iv) Ribbon
  (c)  Which icon on the task bar do you click to open the File 

Explorer window?

   (i)  (ii) 

(iii)  (iv) None of these

  (d) Which of the following is not true about a fi le?
   (i) It contains many other fi les and folders.
   (ii) It is a single document made in any software.
   (iii) It can be renamed.   
   (iv) It can be deleted. 
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  (e)  Which tab of the File Explorer window helps to copy a fi le/
folder?

   (i) Home (ii) Share
   (iii) File (iv) View

4. Answer the following questions.
 (a) What is Windows 8.1?

Ans. It is a GUI-based operating system.
 (b) What is the purpose of the live tiles in Windows 8.1? 

Ans.  In Windows 8.1, some apps use live tiles, which let you see 
 information without even clicking on the app.

 (c)  Aastha wants to change the look of her computer’s desktop. 
Which Windows option should she use to do so? Write steps 
that she would follow.

Ans. She will change the wallpaper. The steps to do this are:
   (i) Place the mouse pointer on the lower right corner to open

the Charms bar, and then select the Settings charm.
   (ii) Select the Personalization option.
   (iii) From the Personalization window, you can choose to 

change the background image or colour scheme.
 (d) How is a screen saver important to a computer system?

Ans.  Screen saver is a moving picture or graphic on the screen that 
protects the screen when not in use.

 (e) Rizak was given holiday assignments on different subjects using 
his home computer. He wants to store all the homework fi les 
together. How should he do this?

Ans.  Rizak can create a special folder named ‘Holidays Hw’. He can 
now drag all the fi les related to his homework into this folder.
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Computer Time

Start your computer and do the following.
Ans. Do it yourself.

Answers of Suggested Class Activities

Ribbon

Folders

Files

Navigation
Buttons

Navigation
Pane

Address Bar Search Bar

Answers of Worksheet

 I. 1. Windows 10 2. Button or key 3. Lock 4. icon
5. Bill Gates

 II. 1. (c) 2. (a) 3. (e) 4. (b) 5. (d)
 III.  1. Alt + Tab 2. All of these 3. Personalization
  4. All of these 5. Restore
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4. Programming with Scratch
Answers of Book

Let’s Do it!
Can you add another sprite (‘Ballerina’, for instance) from the 
library and make it say the following? Join all the blocks together 
as shown below. Click on the blocks to see the result.
Now, let’s make the sprite speak continuously, repeating itself 
over and over again. You can do this by following these steps:

Go to the Control blocks palette and drag the forever block.
Wrap it around the speech blocks. Now, double-click the 

  forever block and see what happens.

Ans. Do it yourself.

Do and Learn!

1. Fill in the blanks.
Ans. (a) Program segments in Scratch are called scripts.

  (b) We can add a new sprite on stage from the built-in library.
  (c)   Blocks are puzzle-piece shapes that are used to create 

code in Scratch.
  (d) There are 10 categories of blocks in Scratch.
  (e) Readymade sound can be added from the Sounds tab.

2. State whether True (T) or False (F).

Ans. (a) Scratch is a typing program. F
  (b) In Scratch, you can create a sprite by painting or
   drawing it using various tools in the Paint Editor. T
  (c) It is not possible to move a sprite on the stage. F
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  (d)  There is only one possible background that can be added 
to the stage.   F

  (e) The forever If () block is a Motion block. F
3. Tick () the correct option:

Ans. (a)  Which of the following blocks are responsible for the 
movement of a sprite on the stage?

   (i) Pen (ii) Looks
   (iii) Motion (iv) Events
  (b)  Which of the following methods can be used to create a 

new sprite?
   (i) Choosing a sprite from the library
   (ii) Painting a new sprite
   (iii) Uploading a sprite from a fi le
   (iv) Any of these
  (c)  Pen blocks are used for drawing lines with the sprite.
   (i) Pen (ii) Events
   (iii) Looks (iv) Motion
  (d) An alternate appearance of a sprite is called its Costume.
   (i) Colour (ii) Path
   (iii) Look (iv) Costume
  (e)  Which of the following blocks of code will help to drag a 

sprite back on to the stage when it reaches its edge while 
moving?

   (i) move 40 steps (ii) turn 30 degrees
   (iii) if on edge, bounce (iv) when clicked

4. Answer the following questions.
 (a) What are the different ways in which we can add a new sprite on 

the stage? Write the steps to use any one method.
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Ans. (a) The different ways are:
    (i)  Choose from library
   (ii) Paint a new sprite
   (iii) Upload sprite from fi le
   (iv) New sprite from camera

Choose from Library: To import a sprite from a built-in 
library of sprites, click the icon that looks like Giga at the 
very left of the bar. A categtory-wise library of sprites opens 
from which you can select a sprite of your choice.

 (b) Can we add more than one sprite on the stage? If yes, write the 
steps to do so.

 Ans.  Yes. Just add a new sprite by following the same procedure or 
steps you follow to add a sprite on the stage. 

 (c) Write the names of all the categories of blocks in Scratch. Mention 
their colours also.

 Ans. Please open Scratch and copy the block names and their 
  colours.
 (d) What is the purpose of the forever () block in creating a script? 

Explain with the help of an example.
Ans.  The forever If () block is a Control block. The block continuously 

checks its condition. If the condition is true, the code inside 
the block will run, and the script continues, but if the condition 
is false, nothing will happen until the condition becomes true 
again. The block continuously runs in a loop; in fact, this block 
works just like the If () block placed in the forever block. After 
being removed, this block is replaced with its workaround.

 (e) Write a short note on the Sounds block in Scratch.
Ans.  Sound blocks are one of the ten categories of Scratch blocks. 

They are colour-coded pink/magenta, and are used to control 
sounds. Drag a sound block on to the script area and click it to 
hear the sound.
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   You can select a different sound of your choice. Simply click 
the drop-down arrow present in the selected Sound block and 
choose the sound from the list that appears. Click the sound to 
play it.

Computer Time!

Open the Scratch software and try each of the following scripts 
one by one. Save both the projects. Use the sprites of your choice 
and also add a background to each project.

Ans. Do it yourself.

Answers of Suggested Class Activities

Answers of Worksheet
 I. 1. Repeat block 2. Stage 3. cat 4. forever 5. forever if ( )
 II. 1. True 2. False 3. True 4. True 5. False
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 III. 
Q R B S C R I P T R S
F D B E K R E T S D P
O R U Q N Z W G J T R
R I S C R A T C H N I
E O Q F P D N L G G T
V K T Y C O S T U M E
E U S T I F Y F D N E
R Z C X J U B V M P N
E S A A F I O N F S T
W M T O D D M T X M D
B T S L I K S O U N D
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5. More About MS Word 2013
Answers of Book

Do and Learn!

1. Fill in the blanks.
Ans. (a) Making changes in typed text is called editing.

  (b) Missing text is typed at the insertion point.
  (c) Replacing existing text with new text is called overtype.
  (d) Moving text is also called cut and paste.
  (e)  To fi nd a particular word or text in the whole document, we 

can use the Find tool of MS Word.

2. Write the keyboard shortcuts for each of the following: 
Ans. (a) Copy: Ctrl + C (b) Paste: Ctrl + F

  (c) Cut: Ctrl + V (d) Find: Ctrl + H
  (e) Replace: Ctrl + X

3. State whether True (T) or False (F).
 Ans. (a)  The Cut and Paste operation is an example of formatting a 

document.   F
  (b)  In MS Word, the cut or copied text is moved to the 

Clipboard.   T
  (c) The keyboard shortcut for cutting text in Word is Ctrl+C.    
      F
  (d) The Find and Replace options delete text. F
  (e) The Delete key removes text to the left of the cursor. F
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4. Tick () the correct option.
Ans. (a) Which of the following is the icon of the Paste button?

(i)    (ii) 



 (iii)    (iv) 

  (b)  To erase text to the left of the cursor, use the Backspace
key.

 (i) Delete   (ii) Backspace
(iii) Left arrow   (iv) Any of these

  (c)  To erase one full word to the right of the cursor, use the 
Ctrl+Delete key(s) from the keyboard.

   (i) Delete (ii) Shift+Delete

(iii) Ctrl+Backspace (iv) Ctrl+Delete
  (d)  The Cut, Copy and Paste buttons are located in the 

Clipboard group of the Home tab.

 (i) Font   (ii) Editing

 (iii) Clipboard   (iv) Paragraph
  (e)  The Cut and paste option will move the selected text in the 

document.
   (i) Copy and paste (ii) Copy and move
   (iii) Cut and copy (iv) Cut and paste

5. Answer the following questions.
 (a)  What do you understand by the term ‘editing’? Give one

 example of editing.
Ans.  The process of making changes in the text is called editing.

For example, editing text.
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 (b) How is the use of the Delete key different from that of the 
  Backspace key?

Ans.  The Delete key deletes to the right of the cursor whereas the 
Backspace key deletes to the left of the cursor.

 (c) Write the steps to copy a word from one place in a document to 
  another.

Ans. The steps are as follows:
     (i) Select the word to be copied by double-clicking on it.
    (ii)  Right-click and choose ‘Cut’.
   (iii) Click at the place where your want to move the word.
   (iv) Right-click and choose ‘Paste’.
 (d) What is the purpose of the Clipboard?

Ans.  Clipboard is a part of the computer’s memory where the cut or 
copied objects stay temporarily.

 (e)  Arnav has typed a document of two pages in MS Word, about 
how he has spent his summer vacation. Now, he wants to 
replace the word ‘summer’ with ‘winter’ in the whole document. 
Which Word tool will help him do so? Write the steps that he 
will follow to do this task.

Ans.  He will use the Find and Replace tool. The steps to use this tool 
 for the task are:

 (i) Press the Ctrl + H keys to open the Find and Replace dialog 
  box.
 (ii)  In the Find what box of the Replace tab, type ‘Summer’.
 (iii) In the Replace with box of the Replace tab, type ‘Winter’.
 (iv) Click the Replace All button.

Computer Time!

 Ans. Do it yourself.
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Answers of Suggested Class Activities

A X Y P H E D C X W T
W V O V E R T Y P E K
C E B H G E Y J M K I
L D A S D P H P M P I
U I H D E L E T E A E
S T Z Q P A N S U S G
F I R Z A C O K J T H
B N N H G E K M B E C
C G O I U J K Y H N O
U M F I N D F M N J P
T B G I R D S X Z Q Y

Answers of Worksheet

 I. 1. True 2. False 3. False 4. True 5. False
 II. 1. Cut; Paste 2. Overtype 3. Ctrl; V 4. replace 5. Editing
 III. 1. Overtype 2. Cut and Paste 3. Copy and Paste
  4. Undo 5. Find
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6.  MS Word 2013 – Formatting Tools
Answers of Book

Do and Learn!

1. Fill in the blanks.
Ans. (a)  The Font colour option is available in the Font group of the 

Home tab.
  (b) Left, center, right and justify are text alignment options.
  (c)  To make a list in MS Word, we can use the bullets or 

numbering option.
  (d)  In Word, the Borders tool is present in the Paragraph group 

of the Home tab.
  (e)   The Line spacing tool helps to increase the gap between 

the different lines of a paragraph.

2. State whether True (T) or False (F).
Ans. (a)  We cannot apply more than one formatting option on a 

selected text.   F
  (b) It is important to select the text before applying any 
   formatting option on it. T
  (c) Justify is a type of text alignment option. T
  (d)  We can either apply a text border or a page border in MS 

Word.   F
  (e) The Increase Indent and Decrease Indent buttons are 
   available in the Paragraph group of the Home tab. T
3. Tick () the correct option.

Ans. (a) Which of the following is the Line Spacing tool icon?
 (i)    (ii) 

(iii)     (iv) 
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  (b) Shading is used for Highlighting the text.

 (i) Highlighting  (ii) Underlining
 (iii) Spacing   (iv) Bordering
  (c) Which of the following is not a formatting tool?
 (i) Font color   (ii) Undo

(iii) Border   (iv) Line Spacing  
  (d)  If you have increased the gap between two lines of a 

paragraph, you have used the Line Spacing tool of MS 
Word.

 (i) Line Spacing  (ii) Line fi lling
 (iii) Bullets and Numbering (iv) None of these
  (e)  The Bullets and Numbering tools are present in the 

Paragraph group of the Home tab.

 (i) Clipboard   (ii) Styles
 (iii) Font   (iv) Paragraph

4. Answer the following questions.
 (a) Name any four formatting tools present in the Font group. Also, 
  write one line about each.

Ans. Bold, Italic, Underline, Font size.
 (b) What do you understand by the term ‘alignment’? Name the 
  different types of alignment options available in MS Word 2013.

Ans.  Alignment means adjusting text within the left and right margins 
of the document page. There are four types of paragraph 
alignment options available in Microsoft Word: left-aligned, 
center-aligned, right-aligned and justifi ed. 

 (c) When are the borders and shading options used?  Write the 
  steps to apply a border to a paragraph.

Ans.  These tools are used to enhance the appearance of text. 
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  To apply a border to text, follow these steps:
   (i) Select the text or paragraph to which you want to add a
    border.
   (ii) Click the down-arrow next to the Border button present in the
    Paragraph group of the Home tab.
    A list of options to put a border around the selected text or

paragraph will appear. You can select any of the options 
available by simply clicking them.

  (iii)  To delete an existing border, simply select the No Border 
option from the border options.

 (d) What is line spacing? Write the steps to apply a line spacing of 
  2.0 points between two paragraphs in a document.

Ans.  This feature of MS Word enables you to change the spacing 
between the lines of text in a single paragraph or between 
different paragraphs. This helps in making the document look 
less congested.

   Steps are:
   (i) Select both the paragraphs.
   (ii) From the Paragraph group of the Home tab, click on Line 

spacing.
   (iii) Select 2.0 line spacing.
 (e) Using MS Word, Jayati has made a list of the students who are 

interested in going to a school trip to Agra. Which tool must
she have used to do so? Write the steps that Jayati must have 
followed to do this task. 

Ans. She must have used the Numbering tool. To create a numbered 
or bulleted list, follow these steps:

   (i)  Click at the place in the document from where you want
to start the bulleted or numbered list.
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   (ii) Click the drop-down arrow next to the Bullets or Numbering 
    tool. A menu with different bullet/numbering styles opens.
   (iii) Select the style of your choice. The fi rst bullet/number
    appears.
   (iv) Type the fi rst point in the list.
   (v) Press the Enter key to get the next bullet/number.

Computer Time

Open MS Word 2013 and do the following.

Ans.  Do it yourself.

Answers of Suggested Class Activities
Ans. Students can do this on their own.

Answers of Worksheet

 I. 1. Center 2. right-alignment 3. Formatting 4. font
  5. numbering
 II.  1. (d) 2. (c) 3. (a) 4. (e) 5. (b)
 III.  1. (a) 2. (d) 3. (b) 4. (d) 5. (c)
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7. Programming with LOGO
Answers of Book

Let’s Test!

Can you name the LOGO primitives to draw the following fi gures?
Ans. Do it yourself.

Do and Learn!

1. Fill in the blanks.
Ans. (a)  The PRINT command in LOGO is used to display words or 

sentences.
  (b) REPEAT 5 [FD 60 RT 360/5] will draw a pentagon.
  (c) A LOGO procedure starts with To.
  (d) To save a LOGO procedure, select the File tab.
  (e)  To delete a procedure, select the Erase option from the 

File tab.
2. State whether True (T) or False (F).
Ans. (a)  In LOGO, the PRINT command can be written as PT also.   

F
  (b) PRINT FIRST [I AM FINE] will give I as the output. T
  (c)  We can draw polygons using the REPEAT command in 

LOGO.   T
  (d)  We can add numbers using the PRINT primitive but we 

cannot subtract numbers using this command. F
  (e) With the help of procedures, we can save LOGO 
   commands permanently. T
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3. Tick () the correct option.
Ans. (a)  The fi le extension of a procedure saved in LOGO is .lgo.

 (i) .logo   (ii) .lgo
 (iii) .lo   (iv) .log
  (b) Which of the following calculations are possible in LOGO?
 (i) Addition   (ii) Subtraction

 (iii) Multiplication   (iv) All of these
  (c)  Which of the following LOGO command statements is 

incorrect?
 (i) PR “I KNOW EVERYTHING
 (ii) PR [I KNOW EVERYTHING]
 (iii) PR SUM 23 56 89
 (iv) PRINT [I KNOW EVERYTHING]
  (d)  A LOGO procedure name should always begin with Letter.
 (i) Number   (ii) $
 (iii) Letter   (iv) Space
  (e)  Which of the following operations is not related to LOGO 

procedures?
   (i) Edit (ii) Save
   (iii) Open (iv) Load

4. Answer the following questions.
 (a) Mention the different options of using the PRINT command in 

LOGO giving one example of each.
Ans. (a)   (i) PRINT – To print a word. For example:

PRINT “Welcome
   (ii) PRINT – To print a sentence. For example:
    PRINT [LOTUS IS A FLOWER]
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   (iii) PRINT – To print a number. For example:
    PRINT 900
   (iv) PRINT FIRST – To print the fi rst character of a word or
    the fi rst word of a sentence. Examples:
    PRINT FIRST “Welcom (output-W)
    PRINT FIRST [This is Fun] (Output. This)
   (v) PRINT – For calculations. For example:
    PR 30 * 5 or PR PRODUCT 30 5
 (b) What is the purpose of the REPEAT primitive in LOGO? Explain 

briefl y with the help of an example.
Ans.  The REPEAT primitive in LOGO is used to repeat a set of 

commands given a number of times. For example, to draw the 
square – FD 40 RT 90, the commands will be repeated four 
times. So we can write REPEAT 4 [FD 40 RT 90].

 (c) What is the advantage of creating a procedure in LOGO? Write 
the steps to create a procedure for drawing a hexagon.

Ans.  Whenever we want to use a particular set of commands again 
and again, we save them in the computer’s memory under a 
procedure name. This way, we don’t have to write the procedure 
again and again.

  Procedure to draw a hexagon:
 1. In HEXA – Type this in Commander window.
 2. In the Input box that appears, type – REPEAT 6[FD 40 RT 
  360/6]
 3. Click OK or press Enter.
 4.  The Input box appears again. Type END and press the 

Enter key.
 5. The defi ned hexagon will appear.
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 (d) Write the steps to: (i) Edit a procedure (ii) Load a procedure
Ans. (i) In LOGO, we can edit a procedure by following these steps:

 1. In the Input box of the Commander window, type EDIT 
  followed by the procedure name.
   The Editor window appears, showing the commands 

used in the procedure.
 2.  If you click the Close button of the Editor window, the 

Contents Changed message box appears, prompting 
you to save the changes you made. Alternatively, you 
can choose the Save and Exit option from the File menu.

 (ii) In LOGO, we can load a procedure by following these steps:
  1. Click the File tab and then select the Load option. The 
   Open dialog box appears.
  2.  Choose the location from the Look in: option in the Open 

dialog box.
  3. Select or write the name of the fi le to be loaded.
  4.  Click the Open button. The selected fi le opens on the 

screen.
 (e) What is the difference between the Save and the Save As 

options?
Ans.  The Save option lets you save a procedure permanently.

If you want to save the procedure with a different name, use 
the Save As option.

Computer Time

Open the LOGO program and do the following.
Ans. Do it yourself.
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Answers of Suggested Class Activities
 1. Repeat 4[FD 30 RT 90] 2. Repeat 2[FD 40 RT 90 FD 20 RT 90]
 3. Repeat 9[FD 40 RT 360/9]

Answers of Worksheet

 I. 1. Body 2. End 3. LOGO promitive 4. letter 5. Edit
 II. 1. (b) 2. (a) 3. (e) 4. (c) 5. (d)
 III.  1. (a) 2. (b) 3. (c) 4. (d)
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8. Introduction to PowerPoint 2013
Answers of Book

Do and Learn!

1. Fill in the blanks.
Ans. (a) MS PowerPoint is an example of presentation software.

  (b)  A presentation is made up of series of slides on any topic.
  (c) Selecting the File tab opens the Backstage view.
  (d)  A picture can be inserted to a slide by selecting the Insert

tab.
  (e) A text box allows the user to type text on a slide. 

2. State whether True (T) or False (F).
Ans. (a)  PowerPoint is part of the MS Offi ce software suite.   

T
  (b) PowerPoint 2013 is a typing program. F
  (c)  We can insert only one object into a single slide. F
  (d) The Slide Sorter View can be used to rearrange 
   slides.   T
  (e) To save a PowerPoint presentation, click the Insert tab. F
3. Tick () the correct option.

Ans. (a) Which of the following is not true about PowerPoint?
(i) It is used for creating slide shows.
(ii) We can add objects like a text box, pictures, sound, 

etc., to slides.
(iii) Each presentation consists of only one slide.

 (iv) The picture option is present in the Insert tab.
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  (b)  The keyboard shortcut for opening a fi le in PowerPoint is 
CTRL + O.

 (i) CTRL+ O   (ii) CTRL+S
 (iii) CTRL+B   (iv) Ctrl+N
  (c)  The dotted box present on the slide is known as a 

Placeholder.
 (i) Placeholder   (ii) Slide show

(iii) Ribbon   (iv) Box
  (d)  To play a slide show, press the F5 key from the keyboard.
 (i) F3   (ii) F2

(iii) F5   (iv) F6
  (e)  Which of the following options are available under the File 

tab?
 (i) Open   (ii) Save
 (iii) Save As   (iv) All of these

4. Answer the following questions.
 (a) Mr Robert wants to teach about the Universe in his Science 

class. He wants to make it very interesting for the students. 
So he decides to make a presentation. Which software do 
you suggest him to use? Mention any two advantages that
Mr Robert will have by showing the presentation to the class.

Ans. Mr Robert can use MS PowerPoint software or any other 
  presentation graphics software. The advantages are:
   (i) It will make the class interesting.
   (ii) Mtr Robert can show pictures and videos through the
    slideshow. The students will enjoy the learning.
 (b) Jahnvi has made a PowerPoint presentation on the topic

‘Swachh Bharat Abhiyan’. She wants to add pictures to her 
presentation. What steps should she follow to add pictures?
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Ans. Jahnvi will follow these steps:
   1. Open the slide on which the picture is to be inserted.
   2. Click the Insert tab.
   3. Select the Pictures option from the Images group.
   4. Locate the picture to be inserted from the Insert Picture
    dialog box.
   5. Click the Insert button.
 (c) Differentiate between the Save and Save As options.

Ans.  The Save option will help you save the presentation. In case 
you want to save an already saved presentation with a different 
name, choose the Save As option.

 (d) Write briefl y about the following:
 (i) Slide Sorter View
 (ii) File tab
 (iii) Slide Navigation pane
Ans. (i) This view displays all the slides in miniature or thumbnail

form. We can rearrange, copy and delete multiple slides 
in this view.

   (ii) Just as in MS Word, MS PowerPoint also has a File tab
which is located to the extreme left of the Ribbon. Clicking 
this tab displays a menu. The menu contains the options 
to open, save, close or print your PowerPoint fi le. You can 
also create a new fi le from here. The File tab view is called 
the Backstage View.

   (iii) The Slide Navigation pane allows you to view and work with 
the slides in your presentation. The selected slide will 
appear in the slide pane to the right. You can add, delete 
and create a duplicate copy of a slide as well as rearrange 
slides in the Slide Navigation pane. 
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 (e) Write the steps to open an existing presentation in PowerPoint.
Ans.  To open an existing presentation in PowerPoint, follow these 

steps:
   1. Select the File tab to go to the Backstage view.
   2. Click Open from the left side of the window. 
   3. Select Computer and then click Browse.
   4. The Open dialog box appears. Locate and select your 

presentation and then click Open to open the presentation.

Computer Time

Open PowerPoint on your job computer and do the following:
Ans. Do it yourself.

Answers of Suggested Class Activities
A.  1. (b) 2. (d) 3. (c) 4. (a) 5. (b)
B.  1. False 2. False 3. True 4. False 5. False

Answers of Worksheet

 I. 1. MS PowerPoint 2. Blank 3. slide show 4. New slide
  5. Insert Picture tool
 II.  1. (e) 2. (d) 3. (c) 4. (b) 5. (a)
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9.  The Internet
Answers of Book

Do and Learn!

1. Fill in the blanks.
Ans. (a) The term ‘Internet’ stands for International Network.

  (b) Google Chrome is a web browser.
  (c) Each website has a unique address, called its URL.
  (d)   E-mail is a way to sending and receiving messages across 

the Internet.
  (e)  Google.com is an example of a search engine.

2.  State whether True (T) or False (F).
Ans. (a)  The Internet is a large network of computers. T

  (b) We don’t need a computer for using the Internet. F

  (c)  The World Wide Web is a search engine. F

  (d) We can send pictures through e-mail. T
  (e) The Refresh button of a web browser will reload the 
   current page.   T
3. Tick () the correct option.

Ans. (a) The Internet is a large Network of computers.
 (i) Group   (ii) Network
 (iii) Cluster   (iv) Line
  (b) WWW stands for World Wide Web.
 (i) World Wise Web (ii) Web World Wide
 (iii) World Wide Web (iv) None of these
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  (c) Which of the following is not a web browser?
 (i) Internet Explorer (ii) Google Chrome
 (iii) Safari   (iv) Gmail
  (d) An e-mail address has the    @    symbol in it.
 (i) @   (ii) #
 (iii) $   (iv) &
  (e)  In the email address arpita@hotmail.com, which part is 

the user name?
 (i) hotmail   (ii) arpita
 (iii) @   (iv) hotmail.com

4. Answer the following questions.
 (a) What is the Internet?

Ans.  The term ‘Internet’ stands for International Network. It consists 
of millions of computers around the world that are connected 
together to share information and resources.

 (b) Mention any two advantages of the Internet.
Ans. Two advantages of the Internet are:

   (i) Communication: The Internet allows us to communicate 
with people sitting at remote locations. Various apps 
available on the Web use the Internet as a medium for 
communication. For example, sending e-mail, live chatting 
and using various social networking websites such as 
Facebook, Twitter, Google+, Orkut, etc.

   (ii) Education and Technology: Visiting different websites 
on the Internet is called surfing or browsing. One can 
surf (browse) the Internet for any kind of information 
regarding various topics such as technology, health, 
science, social studies, geography, etc. 
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 (c) How is a web browser important for the Internet? Give one 
example of a web browser.

Ans. Once you are connected to the Internet, you can open and view 
websites using a special application called a web browser. 
Some popular web browsers are Microsoft’s Internet Explorer, 
Mozilla Firefox, Apple Safari, Google Chrome, Opera, etc. 
(Choose any one from these).

 (d) Write the steps to search for a topic of your choice on the
Internet.

Ans. You can use these steps to search the Internet:
   1. Open any search engine with the help of your browser.
   2. Now, type a keyword to search on the Internet. For

example, type ‘Deserts’ and click the Search button.

  You will see a list of relevant website links that match
your keyword.

   3. If you fi nd a site that looks interesting, you can click its
link to open it. If the site doesn’t have what you need, 
simply return to the results page to look for more options.

 (e) Name the Internet service that you can use to send messages 
to people anywhere in the world.

Ans. E-mail.

Computer Time

With the help of your teacher/parents, open the Internet and using 
a search engine, search for the following topics and write a few 
lines about each topic in your notebook.

Ans. Do it yourself.
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Answers of Suggested Class Activities
A.  1. EMAIL 2. INTERNET 3. MODEM 4. BROADBAND
 5. ONLINE
B. The student can do this with the help of the teacher.

Answers of Worksheet

 I. 1. communication; Internet banking; online shopping
  2. Web browser 3. e-mail 4. address 5. world
 II. 1. True 2. True 3. True 4. True 5. False
 III. 1. (d) 2. (e) 3. (a) 4. (b) 5. (c)
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TESTING TIME – 1
(Based on Lessons 1 to 3)

1. Write ’Input’ or ’Output’ in the blank next to the hardware listed 
below.

Ans. (a) Monitor: Output (b) Keyboard: Input (c) Scanner: Input
  (d) Laser Printer: Output (e) Speakers: Output (f) MICR: Input
  (g) Digital Camera: Input (h) Dot-matrix Printer: Output
  (i) Barcode Reader: Input (j) Joysticks: Input

2. Complete the following table with respect to the components 
of the File Explorer of Windows 8.1.

Ans.
Component Purpose

View Tab Quickly switch between folders.

Ribbon Consists of different tabs with options.

Address Bar You can use the Address bar to know the location of 
the current folder in the hard disk.

Search Bar Use the Search bar to search for particular fi les or 
folders. Simply type the name of the fi le or folder in the 
bar and press the Enter key to locate it.

Navigation 
Buttons

Back and Forward navigation buttons allow you to 
switch between folders.

3. Write full forms of the following terms.
Ans. (a) CD: Compact Disc

  (b) MICR: Magnetic Ink Card Reader
  (c) RAM: Random Access Memory
  (d) CRT:  Cathode Ray Tube
  (e) GB:  Gigabytes
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4. Arrange the following memory units in ascending order of 
their storage capacities.

Ans. 1. Byte 2. Kilobyte 3. Megabyte 4. Terabyte
  5. Petabyte

5. Distinguish between each of the following.
Ans. (a)  RAM and ROM: RAM or Random Access Memory is the 

internal memory of the CPU. It is used for storing data, 
programs and program results. It is a read/write memory 
which means that the data is stored until the computer is 
on. As soon as the computer is switched off, the data gets 
erased.
ROM stands for Read Only Memory. It is the memory from 
which we can only read but cannot write on it. In other 
words, we cannot make any changes in the data stored in 
ROM.

  (b)  Primary memory and secondary memory: A computer 
has two types of memory: primary memory and secondary 
memory. Primary memory holds only the data and 
instructions on which the computer is presently working. 
It is called volatile memory as the data saved here is 
temporary in nature. Primary memory is further divided into 
the following:

   1. RAM (Random Access Memory)
   2. ROM (Random Only Memory)

 Primary memory is expensive as well as limited. If we want 
to store a large amount of data or programs permanently, 
we need a cheaper and permanent memory. Such memory 
is called secondary memory. Secondary memory is stored 
in secondary storage devices, such as hard disk, CD 
(Compact Disc), DVD (Digital Versatile Disc) and pen drive.
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  (c)   CD and DVD: CD or Compact Disk is a circular disk that 
uses laser rays to read and write data. CDs are very cheap 
and have a storage space of 700 MB. They are inserted into 
CD drives fi tted in the CPU box. They are very convenient 
to use and carry with you.
A DVD (Digital Versatile Disc) is similar to a CD in shape 
and size. The only difference lies in the storage capacity. 
The storage capacity of a DVD is around 4.7 GB, which is 
more than that of a CD.
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TESTING TIME – 2
(Based on Lessons 4 to 6)

1. Fill in the blanks by selecting the correct option.
Ans. (a) Small program segments created in Scratch are called 

Scripts.
  (b)  Puzzle-piece shapes used to create Scratch codes are 

called Blocks.
  (c)  A character to the left of the cursor can be deleted using 

the Backspace key.
  (d)  The Subscript feature is available in the Font group of the 

Home tab in MS Word 2013.
(e) Lists can be typed with the help of the Bullets tool in MS Word.

2. Match the following tool icons with their names.
Ans. 1. (c) 2. (d) 3. (a) 4. (e) 5. (b)

3. Write keyboard shortcuts for each of the following actions.
Ans. (a) Find and replace: Ctrl + H (b) Cut: Ctrl + X

  (c) Copy: Ctrl + C (d) Paste: Ctrl + V (e) Save: Ctrl + S

4. Find and write the names of any five MS Word formatting 
tools that are used in the following text.

 Ans. (a) Bold (b) Border (c) Shading (d) Italics (e) Font color
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TESTING TIME – 3
(Based on Lessons 7 to 9)

1. Find the errors in the following LOGO statements and also 
write the correct statements in the space provided.
(a) PRINT “I AM NOW GIVING A TEST 

 Ans. PRINT [“I AM NOW GIVING A TEST]
(b) PRNT FIRST “INDEPENDENCE

 Ans. PR FIRST “INDEPENDENCE
(c) PR DIFF 100 200

 Ans. PR DIFFERENCE 100 200
(d) REPEAT [FD 40 RT 90]

 Ans. REPEAT 4 [FD 40 RT 90]
(e) TO 3AS

 Ans. To A3S

2. Name the following.
 Ans. (a) A fi gure with 8 sides: Octagon

(b) Presentation software: MS PowerPoint
  (c) Each page in a PowerPoint presentation: Slide

(d) Software that helps in surfi ng the Internet: Web Browser
(e) A website’s unique address: URL

3. Answer the following questions.
 (a) If REPEAT 4 [FD 40 RT 90] draws a square in LOGO, what does 
  REPEAT 6 [FD 40 RT 60] draw?
 Ans. A. hexagon
 (b) Mention any two important rules for naming a procedure in
  LOGO.
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 Ans. (i)  Procedure names should always start with a letter. They 
can be followed by numbers and other characters. For 
example, SQUARE1 is a valid name, but 1 SQUARE is 
invalid.

  (ii) Spaces are not allowed within a procedure name. For
   example, SQUARE 1 is a wrong procedure name.
 (c) Name any two components of the PowerPoint screen and write 
  one line about each.
 Ans. (i) File tab: Just as in MS Word, MS PowerPoint also has a 

File tab to the extreme left of the Ribbon. Clicking this tab 
displays a menu. The menu contains the options to open, 
save, close or print your PowerPoint fi le. You can also 
create a new fi le from here. The File tab view is called the 
Backstage View.

  (ii) Ribbon: The Ribbon may look familiar to you as you have 
already worked on it in MS Word. MS PowerPoint has a 
similar Ribbon containing various tabs and buttons to create 
attractive presentations. Each tab consists of commands 
that are divided into categories called groups.

 (d) Write any two functions of the Slide Sorter View of PowerPoint.
 Ans. Copy slides and delete slides.
 (e) In what way is e-mail better than postal mail? Write any two 
  points.
 Ans.  (i) E-mail is very fast.
  (ii) It is inexpensive.

4. Name any fi ve LOGO commands used to draw the following 
fi gures.

Ans. (a) FD (b) RT (c) LT (d) Repeat (e) PU
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5. Simran is working on her computer and using the internet. 
Which software/Internet service is she using for each of the 
following?

Ans. (a) Looking for a home remedy for falling hair. Search engine
  (b)  Sending a letter to her friend in New York through

the Internet.  E-mail
  (c) Going to a previously opened web page. Back button
  (d) Sharing her pictures with many of her online friends.

E-mail attachment
  (e) Playing a game on the Internet. Online gaming

PROJECT WORK
Ans. Do it yourself.
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